Supportforum

Help, Feedback, Feature-Requests, Tipps for OASIS-SVN

Fehler: Das Repository konnte nicht in das angegebene Verzeichnis ausgecheckt...

  • Posts: 4
  • Thank you received: 0

NöhringO created the topic: Fehler: Das Repository konnte nicht in das angegebene Verzeichnis ausgecheckt...

Hallo,

ich will eine existierende DB über den Assistenten einrichten und erhalte nach dem letzten Schritt beim Klick auf Fertigstellen die Fehlermeldung "Fehler: Das Repository konnte nicht in das angegebene Verzeichnis ausgecheckt werden!" - woran kann das liegen?

Versuche ich es über "Verwalten", erscheint plump die Meldung "Aufgrund von Fehlern konnte die Datenbank nicht unter Versionskontrolle gestellt werden" :-(

Environment:

A2016, 64bit,

TortoiseSVN 1.11.1, Build 28492 - 64 Bit , 2019/01/08 21:40:39
ipv6 enabled
Subversion 1.11.1, -release
apr 1.6.5
apr-util 1.6.1
serf 1.3.9
OpenSSL 1.1.0j 20 Nov 2018
zlib 1.2.11
SQLite 3.23.1

Olaf
#480

Please Log in to join the conversation.

GillesB replied the topic: Fehler: Das Repository konnte nicht in das angegebene Verzeichnis ausgecheckt...

Ist das Zielverzeichnis für das Repo evtl. nicht leer? Dann kann es zu Problemen kommen.

Existiert für die DB ein Repository (auf einem Server)?
Wenn nicht, über den Windows-Explorer in einem beliebigen (leeren) Verzeichnis über "TortoiseSVN" => "create repository here" ein neues Repository erzeugen.

Für die DB ein neues Verzeichnis anlegen. In diesem werden die Quellen verwaltet.
Dieses (leere) Verzeichnis über "Checkout" mit dem Repository verbinden.
Das Verzeichnis dann in OASIS als Im- und Exportverzeichnis für die DB festlegen.

Der Assistent macht intern eigentlich nix anderes. Aber es ist immer hilfreich wenn man das Ganze auch "von Hand" einrichten kann.
So kann man SVN auch genz bequem für andere Dinge nutzen (Doku etc.).
#481

Please Log in to join the conversation.

  • Posts: 4
  • Thank you received: 0

NöhringO replied the topic: Fehler: Das Repository konnte nicht in das angegebene Verzeichnis ausgecheckt...

Hallo,

danke für den Hinweis. Ich habe es wie vorgeschlagen per Hand probiert und stellte dabei fest, dass schon SVN eine Meldung bringt, dass ein Repository nicht eingerichtet werden konnte. Daraufhin habe ich SVN (64bit) neu heruntergalden und "repariert".
Jetzt erhielt ich mit dem Assistenten von Oasis die Meldung, dass nicht ausgecheckt werden konnte.
Dies tat ich dann per Hand und habe im Anschluss alle Objekte aus der DB mittels OASIS "Export" in den /Source Pfad exportiert.

Nun scheint alles prima zu funktionieren (getestet an einem Formular das ich veränder habe, beim Commit wurden dann alle Dateien/Objekt-Definitionen "vorgeschlagen")

Danke
Olaf
#482

Please Log in to join the conversation.

Cookies make it easier for us to provide you with our services. With the usage of our services you permit us to use cookies.
Ok